ioby

Why isn't my Youtube video displaying properly?

Is your Youtube video not displaying properly?

You uploaded a Youtube video to your campaign page, and you can see a video thumbnail or poster frame for your campaign video. However, when you attempt to play the video, you receive an error message like the ones below. If this is happening to you, please read on.

Your Youtube video may not be displaying properly for one of two reasons. To determine which, please check the video link you have pasted into the URL box on your ioby campaign page.

(To find this from your project page, click EDIT > then click the the EXTRAS tab. Your video URL will be towards the bottom of the page under any photos you may have uploaded.)

If you have a URL that begins with https://www.youtube.com/, continue to Option 1. If you have a URL that begins with https://youtu.be/, skip to Option 2.

Option 1.

If you have a URL that begins with https://www.youtube.com/ like the example below, please check your link carefully.

If you look closely, you’ll find an ampersand (&) towards the end of your link, followed by more text. This extra text is causing the problem. Please delete any text beginning with "&" onward.

Your original URL:

https://www.youtube.com/watch?v=mx6-zsFCoj8&feature=youtu.be

The URL that will play correctly:

https://www.youtube.com/watch?v=mx6-zsFCoj8

Hit "Submit for Review" to save your changes, and check your campaign page again. Your video should play without a hitch!

Option 2.

If you have a URL that begins with https://youtu.be/ like the example below, please delete it and replace it with the full https://www.youtube.com/ version.

Make sure you’re copying the link from the address bar, not from the "Share a link" bar.

Then delete any text beginning with "&" onward. (These steps are outlined in more detail above in Option 1.)

Your original URL:

 https://youtu.be/mx6-zsFCoj8

The URL that will play correctly:

https://www.youtube.com/watch?v=mx6-zsFCoj8

Hit "Submit for Review" to save your changes, and check your campaign page again. Now your video should play properly!

If you continue to experience difficulties, give us a call or email us at success@ioby.org. For help uploading a video to your campaign page or for troubleshooting problems with a Vimeo video, check out our Support Center.

Did you find this article helpful?